Troubleshooting images in SharePoint news

In recent blogs I showed what can go wrong with images in SharePoint news. So, here’s the recap for everyone who is publishing and sharing SharePoint news and everyone who is supporting them. It will save you time trying to find the cause and solution!

These are the issues, their cause and solution:

  1. No header image visible (News post, News web part and SharePoint landing page)
  2. Header image shows a placeholder image (News post, News web part and SharePoint landing page)
  3. No image visible on Yammer when promoted

1. No header image visible

Does your News post look like this?

This is an example of a news post template with no image
This is the same post, but then on the SharePoint landing page

You (or the publisher) may have selected the “plain” template, this does not have a header.

If this is by design, no action is needed.

If an image is desired, edit the post, click the pencil top right next to the title (1) and select a different template than “Plain” (2). You can now add a header image.

You can easily switch the template to add a header image

2. Header image shows a placeholder image

Does your News post look like this?

The news image is a generic grey image

A News post with a generic grey image on the left can have two causes:

  1. Intended readers have no access to the image.
    The image lives in a place (OneDrive, Document library, Site Assets library) that is not accessible for the intended readers. See my earlier post.
    The issue will be reported by someone who does not have access. The image is visible for the publisher and anyone else who has access.
  2. The image has been deleted or moved after publishing.
    It can take some time before this is noticed, especially by the publisher. The image sticks in the browser cache, so the post will look OK to them. But someone “new” to the post will notice immediately that there is no image.
    In my experiments, the post itself will quickly lose its image and show a grey header, on the News web part it will take some more time, and on the SharePoint landing page it may take even longer!
    In the screenshot below the image is still visible on the SharePoint landing page. (All screenshots have been taken at the same time)
    The SharePoint search index may also have a role in this.
While the image has been deleted, it stays visible for some time on the SharePoint landing page

This can be quite hard to troubleshoot if the publisher does not remember where this image came from. Due to the “stickiness” of the image the issue may only be noticed few days after deletion, which may be quite some time after publishing!

And before you say: “Why bother, the news is outdated after a few months anyway?” remember that this also goes for pages!

You can try the following:

  1. If the publisher remembers the site where it lives, (whether it is the OneDrive or another site) you may want to check the Recycle Bin to see if a deleted image is the problem. Restoring it will solve the issue.
  2. If the publisher remembers the site where it lives, check the permissions to validate the assumption. But rather than changing the permissions for one image, suggest the publisher to download and upload the image, and re-add it to the post.
    It means duplication, but now the image is within control of the publisher.
  3. If the publisher does not remember, things are more difficult.
    It is very unlikely that the Site Assets library or folder of the News site itself will have different permissions from the rest of the site. Nonetheless, to exclude that option, check if there is a folder with the name of the news item in the Site Assets library, and then check permissions of the folder and the image. If yes, inherit the permissions of the site or library again, as unique permissions for a News image are not good practice.
  4. Search for the image. “Images” is now a search vertical. It helps if you know the name!
  5. If this is not the case, there is not much you can do. I tried the F12 “underwater screen” to see if I could find a URL that shows the location of the image (like …my.sharepoint.com/… or the name of the site) but until now I have been unsuccessful. If anyone knows, please let me know!
    You’d better suggest to use another image.

So, this would suggest that using Web Search or Upload is the best source of News images, since you are in control. On the other hand, it means duplication of files which may lead to a lot of clutter all over your tenant.
This may also be your trigger to finally create an Organizational Assets library :).
Agree with the owner that images are not deleted, but hidden in a dedicated view when they are no longer in use, and wait a year or so before deletion. This will keep the images visible on News and pages, but discourage further use.

3. No image visible on Yammer when promoted

While it is very easy to “promote” (share) a SharePoint news post to Yammer, not all news posts show their image when shared.

Does your Yammer post look like this? (I am using “new Yammer”, but not “native Yammer”)

Promoted News item with image, but image does not show on Yammer

That is because the post has been created in an older (not Group-enabled) SharePoint team site. (and not in a modern Group-enabled Team site or Communication site)
There is not much you can do about it except confirm, and inform the publisher that this is how things work. This post explains it in more detail.

Does your Yammer post look like this?

This post has an image placeholder

If the promoted News post only shows an image placeholder, it has been shared from a modern site (Communication or Team) but here the image source is the issue. In my earlier post I found that when you use certain image sources there will be no image on Yammer.
In that case, please suggest to your publisher to use an image from one of the following sources and repost to Yammer:

  • Recent (but beware of copyright issues!)
  • Web Search
  • Upload
  • Organizational Assets
  • From a link to an image in an Assets library (not a regular Document Library!)

Hope this saves you time experimenting!

It is information I wrote before but now turned around into a guide for support folks to help their puzzled users! Hope it is helpful.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s